Read this article carefully before installing this application. If you miss this article, you might not get the application working.



Core Dependencies

As the application is built with Laravel 7, it requires to have all the prerequisites of Laravel 7. One of the dependencies of Laravel is Composer. Here are the core dependencies of the script:


  • PHP >= 7.4
  • MySQL >= 8.0
  • Apache / Nginx


Make sure these dependencies are already installed and working. Here is the link of the list of articles on how to Install above mentioned dependencies:

https://kodemintserviceshelp.freshdesk.com/support/solutions/folders/81000223810


For more details about Laravel Installation, here is the link for the installation guidelines of Laravel: https://laravel.com/docs/7.x.



Additional Requirements

Make sure your application server also meets the following requirements: 


  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Ctype PHP Extension
  • JSON PHP Extension
  • XML PHP Extension
  • GMP PHP Extension (Required for sending Web Push Notification, added on v1.4) 
  • MySQL Native Driver Support
  • GD Image Library
  • Zip Archive Extension
  • Curl (7.70 Min) Support
  • allow_url_fopen enabled
  • SSL installed on server

    


About PHP & cURL Installation

This script requires PHP >= 7.4 and cURL 7.70 in Web and Command Line both

Read following articles on how to check version of PHP running on CLI and on the Web.

https://code.tutsplus.com/tutorials/how-to-check-the-php-version--cms-35322

https://freek.dev/1598-how-to-check-which-version-of-php-you-are-running



About MySQL Installation

There are some points you need to know beforehand:


  • MySQL can be managed through command line but PhpMyAdmin is a free and a great alternative. 
  • For some reason it is causing errors when using MariaDB. Please use MySQL instead of MariaDB!



Required Permissions & Configuration

There are some files and folders which need write permission by the script.

  • .env file located in the root folder
  • storage/framework folder & its sub folder
  • storage/logs folder & its sub folder
  • bootstrap/cache folder & its sub folder
  • resources/lang folder & its sub folder


Your server should allow the script to create symlink (Symbolic Link). If not, you need to do it manually and create a symlink to public/storage folder and point it to storage/app/public folder.


The server must support Authorization Header & Custom Headers. There are few shared hosting plans which do not support this headers. You may not be able to login in this case.


Usually it takes around 10-15 seconds to install but if your server has low resources then it might take 1-2 minutes. In that case, you need to make sure that your PHP Max Execution Time Limit is at least 120 seconds.



For Installation on Local Machine

If you are trying to install it on local machine using WAMP, MAMP or XAMPP, make sure your CURL finds SSL certificate. To know more, visit https://stackoverflow.com/questions/48950599/windows-mamp-php-curl-issue.



Requirements for Customisation

If you are planning to further customize the script, you must have Composer installed in your system. If you don't have knowledge about composer, please click here. Once you have installed the composer in your computer, you need to install Node.js in your system. Here is a good article to install node.js in your computer. You need to install npm globally in your system. Read further articles in sequence to make it work.


Please note that this Script is built on Laravel framework. Prerequisites of Laravel are changed with release of every new version. Prerequisites of this script completely depends upon the prerequisites of Laravel.